USACO-Section 4.1-PROB Beef McNuggets

Beef McNuggets
Hubert Chen

Farmer Brown's cows are up in arms, having heard that McDonalds is considering the introduction of a new product: Beef McNuggets. The cows are trying to find any possible way to put such a product in a negative light.

One strategy the cows are pursuing is that of `inferior packaging'. ``Look,'' say the cows, ``if you have Beef McNuggets in boxes of 3, 6, and 10, you can not satisfy a customer who wants 1, 2, 4, 5, 7, 8, 11, 14, or 17 McNuggets. Bad packaging: bad product.''

Help the cows. Given N (the number of packaging options, 1 <= N <= 10), and a set of N positive integers (1 <= i <= 256) that represent the number of nuggets in the various packages, output the largest number of nuggets that can not be purchased by buying nuggets in the given sizes. Print 0 if all possible purchases can be made or if there is no bound to the largest number.

The largest impossible number (if it exists) will be no larger than 2,000,000,000.

PROGRAM NAME: nuggets

INPUT FORMAT

Line 1: N, the number of packaging options
Line 2..N+1: The number of nuggets in one kind of box

SAMPLE INPUT (file nuggets.in)

3
3
6
10

OUTPUT FORMAT

The output file should contain a single line containing a single integer that represents the largest number of nuggets that can not be represented or 0 if all possible purchases can be made or if there is no bound to the largest number.

SAMPLE OUTPUT (file nuggets.out)

17


dp+数论

无解:n个数中含有1

无数解:所有数gcd不为1

有一个解:简单的背包dp

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#define name "nuggets"
using namespace std;
int dp[100000];
int n,a[12],x;
int gcd(int a,int b)
{
	if (b==0) return a;
	return gcd(b,a%b);
}
int main()
{
	freopen(name ".in","r",stdin);
	freopen(name ".out","w",stdout);
	cin>>n;
	int i,j;
	for (i=1;i<=n;i++)
	{
	    cin>>a[i];
	    if (a[i]==1) {cout<<"0"<<endl;return 0;}
	    if (x==0) x=a[i];else x=gcd(a[i],x);
	    dp[a[i]]=1;
    }
    if (x!=1) {cout<<"0"<<endl;return 0;}
    for (i=1;i<=65536;i++)
	{
		for (j=1;j<=n;j++)
			if (i>=a[j]) dp[i]=dp[i]||dp[i-a[j]];
	}
	for (i=65536;i>=1;i--)
		if (!dp[i]) {cout<<i<<endl;return 0;}
}
/*
Executing...
   Test 1: TEST OK [0.000 secs, 4568 KB]
   Test 2: TEST OK [0.000 secs, 4568 KB]
   Test 3: TEST OK [0.000 secs, 4568 KB]
   Test 4: TEST OK [0.000 secs, 4568 KB]
   Test 5: TEST OK [0.000 secs, 4568 KB]
   Test 6: TEST OK [0.000 secs, 4568 KB]
   Test 7: TEST OK [0.000 secs, 4568 KB]

All tests OK.
YOUR PROGRAM ('nuggets') WORKED FIRST TIME!  That's fantastic
-- and a rare thing.  Please accept these special automated
congratulations.
*/


发布了20 篇原创文章 · 获赞 0 · 访问量 5207

猜你喜欢

转载自blog.csdn.net/SoYouTry/article/details/50659880
今日推荐