POJ2488(A Knight's Journey)(dfs+字典序+回溯)

A Knight's Journey
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 49200   Accepted: 16690

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
思路:一道简单的dfs题,只要遍历完整个棋盘就ok,注意字典序,记得回溯(第一遍忘回溯了WA一发)
上代码:
#include<cstdio>
#include<cstring>
using namespace std;
typedef struct 
{
	int px;
	char py;
} P;
P p[15000];
int chess[35][35];
char tran[]="#ABCDEFGHIJKLMNOPQRSTUVWXYZ";
int n,m;
int flag;
int cnt;
int u;
void dfs(int x,int y)
{
	cnt--;
	chess[x][y]=1;
	p[u].px=x;
	p[u].py=tran[y];
	u++;
	if(cnt==0)
	{
        flag=1;
        return ;
	}
    int dx[8]={-1,1,-2,2,-2,2,-1,1};
    int dy[8]={-2,-2,-1,-1,1,1,2,2};
    for(int i=0;i<8;i++)
    {
        int tx=x+dx[i];
        int ty=y+dy[i];
        if(tx>=1&&tx<=n&&ty>=1&&ty<=m&&chess[tx][ty]==0)
        {
            dfs(tx,ty);
            if(flag==1)
            break;
            chess[tx][ty]=0;
            u--;
			cnt++;
        }
    }
    return ;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int l=1;l<=t;l++)
    {
        scanf("%d%d",&n,&m);
        flag=0;
        for(int i=0;i<34;i++)
        {
        	for(int j=0;j<34;j++)
        	chess[i][j]=1;
        }
        for(int i=1;i<=n;i++)
        {
        	for(int j=1;j<=m;j++)
        	chess[i][j]=0;
        }
        cnt=n*m;
        u=0;
        dfs(1,1);
        if(flag==0)
        printf("Scenario #%d:\nimpossible\n",l);
        else
        {
        	printf("Scenario #%d:\n",l);
        	for(int i=0;i<u;i++)
        	printf("%c%d",p[i].py,p[i].px);
        	printf("\n");
        }
        if(l!=t)
        	printf("\n");
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/star_moon0309/article/details/79852536
今日推荐