1077 Kuchiguse (20分)【字符串处理】

1077 Kuchiguse (20分)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

 解题思路:

该题要我们判断最长的末尾公共子串,要注意的是:输入的字符串可能有空格,因此需要使用getline();

#include<iostream>
#include<string>
using namespace std;
#define MAXN 1e9

string str[110];

int main()
{
	int n;
	cin >> n;
	int minlen = MAXN;
	getchar();
	for (int i = 0; i < n; i++)
	{
		getline(cin, str[i]);
		if (str[i].length() < minlen)
			minlen = str[i].length();
	}
	string res = "";
	for (int i = 0; i < minlen; i++)
	{
		int flag = 1;
		char tmp = str[0][str[0].length() - i - 1];
		for (int j = 1; j < n; j++)
		{
			if (str[j][str[j].length() - i - 1] != tmp)
			{
				flag = 0;
				break;
			}
		}
		if (!flag)
		{
			break;
		}
		else res = tmp + res;
	}
	if (res == "")
		cout << "nai" << endl;
	else cout << res << endl;
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104650087