1077 Kuchiguse (20 分)

1077 Kuchiguse (20 分)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

解题思路:PAT考字符串的题好像挺多,应该多积累一些字符串相关的函数。

getline(cin,s) 输入一整行字符串,可以包含空格,换行符结束

reverse(a,a+m) / reverse(a.begin(),a.end()) 字符串反转函数

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

string s[101];

int main()
{
    int n;
    string ans;
    cin >> n;
    getchar();
    for(int i = 0; i < n; i++){
        getline(cin,s[i]);
    }
    int k = 1;
    char c;
    for(int i = 0; i < 256; i++){//最多不超过256字符
        for(int j = 0; j < n; j++){
            if(j==0){
                c = s[j][s[j].size()-k];//第j个字符串的倒数第k个字符
            }
            else {
                if(k>s[j].size()||s[j][s[j].size()-k]!=c){
                    reverse(ans.begin(),ans.end());
                    if(!ans.empty()) cout << ans;
                    else cout << "nai";
                    return 0;
                }

            }
        }
        ans += c;
        k++;
    }
    reverse(ans.begin(),ans.end());
    cout << ans;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_36313227/article/details/89045254