习题10-6 递归求Fabonacci数列 (10point(s)).c

本题要求实现求Fabonacci数列项的函数。Fabonacci数列的定义如下:

f ( n ) = f ( n 2 ) + f ( n 1 ) ( n 2 ) f ( 0 ) = 0 f ( 1 ) = 1 f(n)=f(n−2)+f(n−1) (n≥2),其中f(0)=0,f(1)=1。

函数接口定义:

int f( int n );

函数f应返回第n个Fabonacci数。题目保证输入输出在长整型范围内。建议用递归实现。

裁判测试程序样例:

#include <stdio.h>

int f( int n );

int main()
{
    int n;

    scanf("%d", &n);
    printf("%d\n", f(n));

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

6

输出样例:

8
//   Date:2020/4/7
//   Author:xiezhg5
#include <stdio.h>

int f( int n );

int main()
{
    int n;

    scanf("%d", &n);
    printf("%d\n", f(n));

    return 0;
}

/* 你的代码将被嵌在这里 */
int f( int n )
{
	int result;
	if(n==0)
		result=0;
	else if(n==1)
		result=1;
	else
		result=f(n-1)+f(n-2);   //前两项之和 
	return result;
}
发布了208 篇原创文章 · 获赞 182 · 访问量 8640

猜你喜欢

转载自blog.csdn.net/qq_45645641/article/details/105358023