7-7 求最大值及其下标 (20分)PTA练习python(简单)

本题要求编写程序,找出给定的n个数中的最大值及其对应的最小下标(下标从0开始)。

输入格式:

输入在第一行中给出一个正整数n(1<n≤10)。第二行输入n个整数,用空格分开。

输出格式:

在一行中输出最大值及最大值的最小下标,中间用一个空格分开。

输入样例:

6
2 8 10 1 9 10

输出样例:

10 2
n=int(input())
list1=input().split()
#对列表的元素进行整型处理
list2=[int(i) for i in list1]
#利用max函数
Max=str(max(list2))
index_M=list1.index(Max)
print(Max,index_M)

发布了39 篇原创文章 · 获赞 8 · 访问量 1742

猜你喜欢

转载自blog.csdn.net/qq_42753878/article/details/105301696