第3章-7 求最大值及其下标 (20分)【python】

本题要求编写程序,找出给定的n个数中的最大值及其对应的最小下标(下标从0开始)。

输入格式:
输入在第一行中给出一个正整数n(1<n≤10)。第二行输入n个整数,用空格分开。

输出格式:
在一行中输出最大值及最大值的最小下标,中间用一个空格分开。

输入样例:
6
2 8 10 1 9 10

      
    
输出样例:
10 2

a = int(input())
list = input().split()
max = int(list[0])
index = 0
i = 1
while i<a:
    if(max<int(list[i])):
        max = int(list[i])
        index = i
    i+=1
print("%d %d"%(int(list[index]),index))
exit(0)
发布了363 篇原创文章 · 获赞 95 · 访问量 18万+

猜你喜欢

转载自blog.csdn.net/qq_43788669/article/details/105395112