poj 2452 Sticks Problem

Description
Xuanxuan has n sticks of different length. One day, she puts all her sticks in a line, represented by S1, S2, S3, ...Sn. After measuring the length of each stick Sk (1 <= k <= n), she finds that for some sticks Si and Sj (1<= i
 < j <= n), each stick placed between Si and Sj is longer than Si but shorter than Sj.

Now given the length of S1, S2, S3, …Sn, you are required to find the maximum value j - i.
Input
The input contains multiple test cases. Each case contains two lines.

Line 1: a single integer n (n <= 50000), indicating the number of sticks. 
Line 2: n different positive integers (not larger than 100000), indicating the length of each stick in order.

Output
Output the maximum value j - i in a single line. If there is no such i and j, just output -1.
Sample Input
4
5 4 3 6
4
6 5 4 3

Sample Output
1
-1

题意:找到一个最长的区间,这个区间中间每个数字都要小于末尾的数,并且要大于区间开头的数,输出符合要求的最大区间长度
思路:先记录每一位数后面连续大于这个数的长度,然后再这个长度里找最大的数,这样可求得最大的区间

原文链接:https://blog.csdn.net/libin56842/article/details/12461031

方法一:python

#暴力检索
n = int(input())
sticks = list(map(int, input().split(' ')))
maxlen = -1
for i in range(n):
    j = i+1
    maxvalue = 0
    maxj = -1
    while j < n and sticks[j] > sticks[i]:
        if sticks[j] > maxvalue:
            maxvalue = sticks[j]
            maxj = j
        j += 1
    if maxj-i > maxlen:
        maxlen = maxj-i
print(maxlen)

总感觉哪里有点问题,但还没看出来。没有online judge

改进:下一个i从j开始判断,减少检索次数

n = int(input())
sticks = list(map(int, input().split(' ')))
maxlen = -1
i = 0

while i < n:
    j = i+1
    maxvalue = 0
    maxj = -1
    while j < n and sticks[j] > sticks[i]:
        if sticks[j] > maxvalue:
            maxvalue = sticks[j]
            maxj = j
        j += 1
    if maxj - i > maxlen:
        maxlen = maxj - i
    if j < n:
        i = j
    else:
        break

print(maxlen)
发布了64 篇原创文章 · 获赞 10 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_34505594/article/details/100031070