POJ2104-K-th Number(浅析主席树)

K-th Number
Time Limit: 20000MS   Memory Limit: 65536K
Total Submissions: 65162   Accepted: 22979
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion

具体关于主席树戳这里

Code:

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#define N 100005
using namespace std;
int cnt=1,rank[N],root[N];
struct node
{
	int id,value;
}a[N];
struct tree
{
	int l,r,sum;
	tree()
	{
		sum=0;
	}
}tree[20*N];
int cmp(node x,node y)
{
	return x.value<y.value;
}
void update(int num,int &rt,int l,int r)
{
	tree[cnt++]=tree[rt];
	rt=cnt-1;
	tree[rt].sum++;
	if(l==r)return;
	int mid=(l+r)>>1;
	if(num<=mid)update(num,tree[rt].l,l,mid);
	else update(num,tree[rt].r,mid+1,r);
}
int query(int i,int j,int k,int l,int r)
{
	int d=tree[tree[j].l].sum-tree[tree[i].l].sum;
	if(l==r)return l;
	int mid=(l+r)>>1;
	if(k<=d)return query(tree[i].l,tree[j].l,k,l,mid);
	else return query(tree[i].r,tree[j].r,k-d,mid+1,r);
}
int main()
{
	int n,T;
	scanf("%d%d",&n,&T);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i].value);
		a[i].id=i;
	}
	sort(a+1,a+n+1,cmp);
	for(int i=1;i<=n;i++)
		rank[a[i].id]=i;
	for(int i=1;i<=n;i++)
	{
		root[i]=root[i-1];
		update(rank[i],root[i],1,n);
	}
	while(T--)
	{
		int l,r,k;
		scanf("%d%d%d",&l,&r,&k);
		printf("%d\n",a[query(root[l-1],root[r],k,1,n)].value);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_34531807/article/details/80342868