2019ICPC 沈阳重现 L-Flowers(二分)

7-7 L-Flowers
Recently Jack becomes much more romantic. He would like to prepare several bunches of flowers.

Each bunch of flowers must have exactly M flowers. As Jack does not want to be boring, he hopes that flowers in the same bunch are all different species. Now there are N species of flowers in the flower shop, and the number of the i-th species of flower is a​i. Now Jack would like to know how many bunches of flowers he can prepare at most.

(Flowers are used to propose.)
Sample Input
1
5 3
1 1 1 2 1

Sample Output
2
思路:二分答案,看一下共x朵花,每朵花m个不同的花组成能不能满足就行了。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=3e5+1; 
int T,n;
ll k,a[maxn];
bool check(ll x)
{
	ll sum=0;
	for(int i=1;i<=n;++i) sum+=min(a[i],x);
	return sum>=x*k;
}
int main()
{
	scanf("%d",&T);
	while(T--)
	{
		ll sum=0;
		scanf("%d %lld",&n,&k);
		for(int i=1;i<=n;++i) scanf("%lld",&a[i]),sum+=a[i]; 
		ll l=0,r=sum,mid;
		while(l<=r)
		{
			mid=(l+r)>>1;
			if(check(mid)) l=mid+1;
			else r=mid-1;
		}
		printf("%lld\n",r);
	} 
}
发布了328 篇原创文章 · 获赞 1 · 访问量 9111

猜你喜欢

转载自blog.csdn.net/qq_42479630/article/details/105169356
今日推荐