GYM 101653 M.Polyhedra Given(水~)

Description

已知所有凸多面体的欧拉示性数 x = V E + F = 2 ,其中 V , E , F 分别为顶点数、边数和面数,现在给出一个凸多面体的点数和边数,求面数

Input

第一行一整数 T 表示用例组数,每组用例输出两个整数 V , E 表示一个凸多面体的点数和边数

( 1 T 100 , 4 V , E 100 )

Output

输出面数 F

Sample Input

2
8 12
4 6

Sample Output

6
4

Solution

简单题, F = E + 2 V

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int main()
{
    int T,V,E,F;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&V,&E);
        F=E+2-V;
        printf("%d\n",F);
    } 
    return 0;
}

猜你喜欢

转载自blog.csdn.net/v5zsq/article/details/80404851