hdu6434 Problem I. Count(数论)(好题)

题目链接
Problem Description
Multiple query, for each n, you need to get
n i-1
∑ ∑ [gcd(i + j, i - j) = 1]
i=1 j=1

Input
On the first line, there is a positive integer T, which describe the number of queries. Next there are T lines, each line give a positive integer n, as mentioned above.
T<=1e5, n<=2e7

Output
Your output should include T lines, for each line, output the answer for the corre- sponding n.

Sample Input
4
978
438
233
666

Sample Output
194041
38951
11065
89963

Source
2018 Multi-University Training Contest 10
思路:在这里插入图片描述
变换差不多就是这样,于是对于每一个i就变成了求2i的欧拉函数除2了,求一下前缀和就行。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=2e7+5;
ll euler[N<<1],sum[N],prim[N<<1];
void get_euler(int n){ //欧拉函数 
   memset(euler, 0, sizeof euler);
  euler[1] = 1;
  int id = 0;
  for(int i = 2; i < n; ++i) {
    if(!euler[i]) {
      euler[i] = i - 1;
      prim[id++] = i;
    }
    for(int j = 0; j < id && prim[j]*i <n; ++j) {
      if(i % prim[j]) {
        euler[i*prim[j]] = euler[i] * (prim[j]-1);
      } else {
        euler[i*prim[j]] = euler[i] * prim[j];
        break;
      }
    }
  }
}
int main()
{
    int n,T;
    get_euler(N<<1);
    sum[1]=0;
    for(int i=2;i<=N;++i) sum[i]=euler[2*i]/2,sum[i]+=sum[i-1];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        printf("%lld\n",sum[n]);
    }
}
发布了283 篇原创文章 · 获赞 0 · 访问量 7317

猜你喜欢

转载自blog.csdn.net/qq_42479630/article/details/105017933