PAT 甲 1035 Password

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.
Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.
Sample Input 1:
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 R@spodfa
Sample Input 2:
1
team110 abcdefg332
Sample Output 2:
There is 1 account and no account is modified

Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:
There are 2 accounts and no account is modified
题意:
1.首先输入n,接着输入n行,每行输入一个用户的姓名和密码,然后对密码中出现的1、0、l、O分别改为@、%、L、o,然后先输出需更改的用户数量,在输出更改之后的每个用户的姓名和密码
2.如果不存在需要修改的,则输出There are N accounts and no account is modified,如果不存在需要修改的且只有一个用户,输出There is 1 account and no account is modified
思路:
输入姓名密码时就对密码判断是否更改,然后将更改后的密码和姓名拼接存储到vector中,然后可以根据vector中元素的数量来判断有多少已经更改的。
C++代码:

#include<cstdio>
#include<iostream> 
#include<vector>
using namespace std;
int main(){
	int n;
	cin>>n;
	vector<string> s;
	for(int i=0;i<n;i++){
		string name,str;
		cin>>name>>str;
		int len=str.length();
		bool flag=true;
		for(int j=0;j<len;j++){
			if(str[j]=='1'){
				str[j]='@';
				flag=false;
			}
			else if(str[j]=='0'){
				str[j]='%';
				flag=false;
			} 
			else if(str[j]=='l'){
				str[j]='L';
				flag=false;
			}
			else if(str[j]=='O'){
				str[j]='o';
				flag=false;
			}
		}
		if(!flag){
			string tmp=name+" "+str;//name 和 更新后的passward拼接起来用vector存储 
			s.push_back(tmp);
		}
	}
	int len1=s.size();
	if(len1!=0){
		printf("%d\n",len1);
		for(int i=0;i<len1;i++){
			cout<<s[i]<<endl;
		}
	}
	else if(n==1){
		cout<<"There is 1 account and no account is modified"<<endl;
	}
	else{
		cout<<"There are "<<n<<" accounts and no account is modified"<<endl;
	}
	return 0;
} 
发布了65 篇原创文章 · 获赞 5 · 访问量 4148

猜你喜欢

转载自blog.csdn.net/u014424618/article/details/105038380
今日推荐