PAT A1085 Perfect Sequence (25分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805381845336064

题目描述
Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

输入
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10^​5​​ ) is the number of integers in the sequence, and p (≤10^​9​​ ) is the parameter. In the second line there are N positive integers, each is no greater than 10^​9​​ .

输出
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

样例输入
10 8
2 3 20 4 5 1 6 7 8 9

样例输出
8

代码

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;
int n, p, a[maxn];

int main() {
	scanf("%d%d", &n, &p);
	for(int i = 0; i < n; i++)
		scanf("%d", &a[i]);
	sort(a, a + n);
	int ans = 1;
	for(int i = 0; i < n; i++) {
		int j = upper_bound(a + i + 1, a + n, (long long)a[i] * p) - a;
		ans = max(ans, j - i);
	}
	printf("%d\n", ans);
	return 0;
}
发布了288 篇原创文章 · 获赞 12 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104748931
今日推荐