PAT甲级--1085 Perfect Sequence(25 分)【@水题】

1085 Perfect Sequence(25 分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

 解题思路:这题虽然简单,但是一开始没有拿到满分,错误如下:第一,最大值只有一个,但是最大值可能出现了多次,所以我们不用lower_bound函数而是用upper_bound函数,最大值都放在这个序列,这样长度就会更长;第二,忽略了相乘的结果的类型,p是不超过10^9,但是如果相乘那就可能超过了,所以将vector类型转换成long long类型,最后就对了。

#include<bits/stdc++.h>
using namespace std;
int main(void)
{
	int n;
	long long p;
	scanf("%d%lld",&n,&p);
	vector<long long>v(n); 
	int a,min=INT_MAX;
	for(int i=0;i<n;i++)
	{
		scanf("%lld",&v[i]);
	}
	sort(v.begin(),v.end());
	int maxm=0;
	for(int i=0;i<n;i++)
	{
		int temp=upper_bound(v.begin(),v.end(),v[i]*p)-v.begin();
		if((temp-i)>maxm) maxm=temp-i;
	}
	cout<<maxm<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82318090