Theory + experiment dynamic routing protocol------ISIS

Briefly describe IS-IS dynamic routing protocol

  1. Link state protocol, using SPF algorithm
  2. Use Hello packet to establish neighbor relationship, use LSP to exchange link state information, adopt hierarchical design
  3. There are two routing levels, L1 and L2.
    L1 is responsible for spreading link state information in the same area (similar to type 1 and 2 in OSPF)
    L2 is responsible for spreading link state information to each other in different areas (similar to OSPF Category 3)
  4. Three kinds of routers: L1 can obtain the path information in the
    area , L2 can obtain the path information between the areas,
    L1-2: Can obtain the intra-area and inter-area paths at the same time
  5. The path connecting the L2 router and the L1/L2 router will form a backbone area
  6. The IS-IS area boundary is located on the link, not in the router, each IS-IS router belongs to only one area

Neighbor relationship graph

Area1 --------L1-------Area1
R1(L1)------------------R2(L1)

Area1 -----None-------Area1
R1(L2)------------------R2(L1)

Area1 -------- L2 ------- Area1
R1 (L2) ------------------ R2 (L1-2)

Area1 ------None-----Area2
R1(L1)------------------R2(L1-2)

Area1 -------- L2 ------- Area2
R1 (L2) ------------------ R2 (L1-2)

Area1 --------L1L2-------Area2
R1(L1-2)----------------R2(L1-2)

NSAP address

1. The NSAP address is 8-20 bytes, identified in hexadecimal, and contains the following main information:

【1】Region number

[2] System number (fixed 6 bytes)

[3] NSEL bit (fixed 1 byte and set to 0)

For example: 49.0001.0002.0002.0002.00

2. Common planning methods for NET addresses in existing networks

It can be obtained by complementing the 32-bit address of the loopback port into 48 bits.
For example: 221.15.23.180 ### fills in 3 bits, then 4 bits are divided into
221.15.23.180 ------> 221.015.023.180 ------> 2210.1502 .3180
after conversion: 49.0020.2210.1502.3180.00

Zone 1
12.12.12.12 ------> 0120.1201.2012 ------> 49.0001.0120.1201.2012.00

Area 30
218.120.130.11 ------> 2181.2013.0011 ------> 49.0030.2181.2013.0011.00

IS-IS protocol configuration roadmap

  1. Start the IS-IS process and configure the NET address according to the regional plan
  2. Configure IS-IS routing type according to network structure
  3. Under the interface, announce the mouth to the IS-IS process

Insert picture description here

R1 placement

interface GigabitEthernet0/0/0                                		   	     //设置接口
 ip address 16.0.0.1 255.255.255.252
 
 interface GigabitEthernet0/0/1
 ip address 12.0.0.1 255.255.255.252
 isis enable 1									      //启动ISIS

interface LoopBack0								     //创建环回口
 ip address 1.1.1.1 255.255.255.255						     //设置IP
 isis enable 1

isis 1										//isis 后面跟进程。默认不加就是1进程
 is-level level-1			      		     //根据网络结构配置IS-IS路由类型,这边有路由器类型
 network-entity 49.0001.0010.0100.1001.00					//设置NSAP地址
 import-route rip 1 level-1							//引入后变成l1信息  默认值
 summary 203.0.0.0 255.255.254.0 level-1					//域间路由汇总

rip 1
 undo summary									//取消汇总
 version 2
 network 16.0.0.0								//宣告网段
 import-route isis 1 cost 5						//引入ISIS 1 路由条目 累加 cost 5 是花销
引路由

R2 configuration

interface GigabitEthernet0/0/0
 ip address 23.0.0.1 255.255.255.252
 isis enable 1

interface GigabitEthernet0/0/1
 ip address 12.0.0.2 255.255.255.252
 isis enable 1

interface LoopBack0
 ip address 2.2.2.2 255.255.255.255
 isis enable 1
 
 isis 1
 network-entity 49.0001.0020.0200.2002.00
 import-route isis level-2 into level-1

R3 configuration

interface GigabitEthernet0/0/0
 ip address 23.0.0.2 255.255.255.252
 isis enable 1

interface GigabitEthernet0/0/1
 ip address 34.0.0.1 255.255.255.252
 isis enable 1

interface LoopBack0
 ip address 3.3.3.3 255.255.255.255
 isis enable 1

isis 1
 is-level level-2
 network-entity 49.0000.0030.0300.3003.00

R4 configuration

interface GigabitEthernet0/0/0
 ip address 45.0.0.1 255.255.255.252
 isis enable 1

interface GigabitEthernet0/0/1
 ip address 34.0.0.2 255.255.255.252
 isis enable 1

interface LoopBack0
 ip address 4.4.4.4 255.255.255.255
 isis enable 1

isis 1
 network-entity 49.0002.0040.0400.4004.00
 import-route isis level-2 into level-1
 summary 202.0.0.0 255.255.254.0 level-1-2

R5 configuration

interface GigabitEthernet0/0/0
 ip address 45.0.0.2 255.255.255.252
 isis enable 1
 isis cost 22

interface LoopBack0
 ip address 5.5.5.5 255.255.255.255
 isis enable 1

interface LoopBack1
 ip address 202.0.0.1 255.255.255.0
 isis enable 1
 
interface LoopBack2
 ip address 202.0.1.1 255.255.255.0
 isis enable 1
 
isis 1
 is-level level-1
 network-entity 49.0002.0050.0500.5005.00

R6 configuration

interface GigabitEthernet0/0/0
 ip address 16.0.0.2 255.255.255.252

interface LoopBack0
 ip address 6.6.6.6 255.255.255.255

interface LoopBack1
 ip address 203.0.0.1 255.255.255.0

interface LoopBack2
 ip address 203.0.1.1 255.255.255.0

rip 1
 undo summary
 version 2
 network 16.0.0.0
 network 6.0.0.0
 network 203.0.0.0
 network 203.0.1.0

Guess you like

Origin blog.csdn.net/weixin_48190875/article/details/107087481