D - Phone List HDU - 1671(字典树先排序)

 D - Phone List HDU - 1671

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits. Output For each test case, output “YES” if the list is consistent, or “NO” otherwise. Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES

先排序下他们的字符串的长度

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
const int N = 200000;
string S[100005];
string s;
struct node
{
	int flag;
	node *next[12];
	node(){
		flag = 0;
		memset(next,NULL,sizeof(next));
	}
};
node *root;
bool build(string s)
{
	node *p = root;
	int len=s.length();
	for(int i=0;i<len;i++)
	{
		int j = s.at(i)-'0';
		if(p->next[j]==NULL)
		{
			p->next[j] = new node();
		}
		else if(p->next[j]!=NULL)
		{
			if(p->next[j]->flag==1)
			return false;
		}
		p = p->next[j];
	}
	p->flag=1;
	return true;
}
bool cmp(string a,string b)
{
	return a.length()<b.length();
}
void del(node *root)
{
	for(int i=0;i<12;i++)
	{
		if(root->next[i]!=NULL)
			del(root->next[i]);
	}
	delete(root);
}
int main(){
	int t;cin>>t;
	char s[1000];
	while(t--)
	{
		int flag = 0;
		root = new node;
		int n ;cin>>n;
		for(int i=1;i<=n;i++)
		{
			cin>>S[i];
		}
		sort(S+1,S+1+n,cmp);
		for(int i=1;i<=n;i++)
		{
			if(build(S[i])==false)
			{
				flag=1;
				break;
			}
		}
		if(flag == 1)printf("NO\n");
		else printf("YES\n");
		del(root);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/80141871
今日推荐