SCAU2020春季个人排位赛div2 #2----G

简单说下

这道题目的大致意思是如何安排写作业顺序,使得被扣分最少。
这题很明显的是一道贪心了;
说到贪心,那如何贪心呢?
要保证利益最大,所以一定要从分多的开始。
所以我们先对任务排一下序,让分高的在前面,
我们使用一个数组来记录改时刻下的time是否被用过。
然后我们从分到到分小依次枚举,对于分所对应的时间我们逆序检查,对于用过的时间我们置为1,若最后找不到对应的时间可以用,则此时的分是要被罚的分。

题目如下

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Output
For each test case, you should output the smallest total reduced score, one line per test case.
Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
Sample Output
0
3
5

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
using namespace std;
#define ll long long
typedef struct
{
    int time;
    int score;
}NODE;
bool cmp(NODE x,NODE y)
{
    if(x.score!=y.score) return x.score>y.score;
        else return x.time<y.time;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n,ans=0;
        cin>>n;
        NODE str[1005];
        bool tl[1005]={0};
        for(int i=1;i<=n;i++)
            cin>>str[i].time;
        for(int i=1;i<=n;i++)
            cin>>str[i].score;
        sort(str+1,str+n+1,cmp);
        for(int i=1;i<=n;i++)
        {
            int j;
            for(j=str[i].time;j>0;j--)
            {
                if(!tl[j])
                {
                    tl[j]=1;
                    break;
                }
            }
            if(j==0)
              ans+=str[i].score;
        }
        cout<<ans<<endl;
    }
    return 0;
}
发布了43 篇原创文章 · 获赞 26 · 访问量 3085

猜你喜欢

转载自blog.csdn.net/Leo_zehualuo/article/details/104462247
今日推荐