c++编程练习 041:Set

北大程序设计与算法(三)测验题汇总(2020春季)


描述

现有一整数集(允许有重复元素),初始为空。我们定义如下操作:
add x 把x加入集合
del x 把集合中所有与x相等的元素删除
ask x 对集合中元素x的情况询问
对每种操作,我们要求进行如下输出。
add 输出操作后集合中x的个数
del 输出操作前集合中x的个数
ask 先输出0或1表示x是否曾被加入集合(0表示不曾加入),再输出当前集合中x的个数,中间用空格格开。

输入
第一行是一个整数n,表示命令数。0<=n<=100000。
后面n行命令,如Description中所述。

输出
共n行,每行按要求输出。

样例输入
7
add 1
add 1
ask 1
ask 2
del 2
del 1
ask 1

样例输出
1
2
1 2
0 0
0
2
1 0

提示
Please use STL’s set and multiset to finish the task


分析

set模板的使用

#include <set>
#include <string>
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
	multiset<int> sets;
	set<int> be_sets;
	int n;
	cin >> n;
	char cmd[20];
	int  num;
	set<int>::iterator li;
	while (n--) {
		cin >> cmd;
		int count = 0;
		switch (cmd[1]) {
		case 'd':
			cin >> num;
			sets.insert(num);
			be_sets.insert(num);
			cout << sets.count(num) << endl;
			break;
		case 'e':
			cin >> num;
			cout << sets.count(num) << endl;
			for (li = sets.begin(); li != sets.end(); li++){
				if (*li == num){
					sets.erase(li);
				}
			}
			break;
		case 's':
			cin >> num;
			if (be_sets.find(num) != be_sets.end()) {
				cout << 1 << " " << sets.count(num) << endl;
			}
			else
				cout << 0 << " " << sets.count(num) << endl;
			break;
		}
	}
	return 0;
}
发布了222 篇原创文章 · 获赞 48 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_44116998/article/details/104419595
今日推荐