杭电oj1236成绩排名

题目描述

今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。

Input

测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。

Output

对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。

Sample Input

4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0

Sample Output

3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct student
{
	char name[25];
	int score;
};
bool cmp(student &a,student &b){
	if(a.score!=b.score)
	return a.score>b.score;
	else
	return strcmp(a.name,b.name)<0;//值为负时为升序 
}
int main(){
	//N为考生数 M为考题数 G为分数线 
	int N,M,G,num,i,m;//num是同学做对的题目的数量 
	int arr[15];//用来记录题目的分值 
	student stu[1010];
	while(1){
		cin>>N; 
		if(N==0)
		 break;
		 cin>>M>>G;
		int count=0;
		for(i=1;i<=M;i++){
			cin>>arr[i];
		}//输入题目的分值 
		for(i=1;i<=N;i++){
			cin>>stu[i].name>>num;
			stu[i].score=0;
			while(num--){
				cin>>m;//输入做对的题号 
				stu[i].score+=arr[m];//做对的题对应的分值 
			}
			if(stu[i].score>=G)
			   count++;
			
		}//for 循环输入每个学生的信息
		sort(stu+1,stu+N+1,cmp);/*是从stu+1开始!因为录学生信息时需要从1开始*/ 
		cout<<count<<endl;
		for(i=1;i<=count;i++)
		cout<<stu[i].name<<" "<<stu[i].score<<endl;
		
	}
	return 0;
}

他这里有个提示
Huge input, scanf is recommended.
但是我没有scanf 用的cin也AC了,为什么用scanf呢

发布了13 篇原创文章 · 获赞 0 · 访问量 203

猜你喜欢

转载自blog.csdn.net/weixin_45191675/article/details/104696263