电影节

Problem Description

某届电影节评选电影,共有两部电影进入最后评选环节,有n名观众,每个人有一次投票的机会,每个人都按照规则投给其中一部电影。为了了解情况,记者随机询问了一些人,一共询问了m次,特别神奇的是,记者每次都询问两个人,而且这两个人都把票投给了同一部电影,观众编号为1~n。

Input

多组输入,每组第一行是两个整数n,m (2 <= n <=100000,0 <= m < n/2),接下来m行数据,表示m次询问,每行数据有两个整数a,b代表观众的编号(1 <= a,b <= n),观众a和观众b投票给了同一部电影,接下来一行是两个整数c,d(1 <= c,d <= n)。

Output

对于每一组输入,输出一行,如果观众c和观众d投票给同一部电影,输出”same”,如果不能确定,输出”not sure”。

Example Input

5 2
1 2
2 3
1 3
5 2
1 2
3 4
1 4
5 2
1 2
3 4
2 5

Example Output

same
not sure
not sure

Hint

 

Author

xj
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e5 +5;
const int INF = 0x3f3f3f3f;
int pre[maxn], deep[maxn];
int Find(int x) {
    return pre[x] == x ? x : Find(pre[x]);
}
void Unite(int x, int y) {
    x = Find(x);
    y = Find(y);
    if(x == y) {
        return;
    }
    if(deep[x] < deep[y]) {
        pre[x] = y;
    } else {
        pre[y] = x;
        if(deep[x] == deep[y]) {
            deep[x]++;
        }
    }
}
void CSH(ll n) {
    memset(deep, 0, sizeof(deep));
    for(int i = 1; i <= n; i++) {
        pre[i] = i;
    }
}
void SR(ll m) {
    while(m--) {
        ll x, y;
        scanf("%d%d", &x, &y);
        Unite(x, y);
    }
}
void SC() {
    ll c, d;
    scanf("%lld%lld", &c, &d);
    if(Find(c) == Find(d)) {
        printf("same\n");
    } else {
        printf("not sure\n");
    }
}
int main() {
    ll n, m;
    while(~scanf("%lld%lld", &n, &m)) {
        CSH(n);
        SR(m);
        SC();
    }
    return 0;
}


/***************************************************
User name:
Result: Accepted
Take time: 168ms
Take Memory: 692KB
Submit time: 2018-02-01 09:33:42
****************************************************/

猜你喜欢

转载自blog.csdn.net/qwqwdqwqwe/article/details/79232854