电影节(并查集)

电影节

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

某届电影节评选电影,共有两部电影进入最后评选环节,有n名观众,每个人有一次投票的机会,每个人都按照规则投给其中一部电影。为了了解情况,记者随机询问了一些人,一共询问了m次,特别神奇的是,记者每次都询问两个人,而且这两个人都把票投给了同一部电影,观众编号为1~n。

Input

多组输入,每组第一行是两个整数n,m (2 <= n <=100000,0 <= m < n/2),接下来m行数据,表示m次询问,每行数据有两个整数a,b代表观众的编号(1 <= a,b <= n),观众a和观众b投票给了同一部电影,接下来一行是两个整数c,d(1 <= c,d <= n)。

Output

对于每一组输入,输出一行,如果观众c和观众d投票给同一部电影,输出”same”,如果不能确定,输出”not sure”。

Sample Input

5 2
1 2
2 3
1 3
5 2
1 2
3 4
1 4
5 2
1 2
3 4
2 5

Sample Output

same
not sure
not sure

Hint


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int f[100000];
int getf(int u)
{
    if(u == f[u])return u;
    f[u] = getf(f[u]);
    return f[u];
}
void link(int u,int v)
{
    int t1 = getf(u),t2 = getf(v);
    if(t1 != t2)
    {
        f[t1] = t2;
    }
}
int main()
{
    int n , m, i, c,d,u,v;
    while(~scanf("%d %d",&n,&m))
    {
        for(i = 1;i <= n;i++)
        {
            f[i] = i;
        }
        for(i = 1;i<=m;i++)
        {
            scanf("%d %d",&u,&v);
            link(u,v);
        }
        scanf("%d %d",&c,&d); 
        if(getf(c) == getf(d))printf("same\n");   //刚开始提交错在这里..写成了f[c] == f[d]~
        else printf("not sure\n");
    }
    return 0;
}

要理解getf()函数的意思就是寻找‘首领’~f[i]有的时候只能代表它的上一层是谁~

猜你喜欢

转载自blog.csdn.net/weixin_40616644/article/details/81908660
今日推荐