2016年ICPC中国大陆区域赛(沈阳)A题

题目网址点击进入

Problem Description
ACM ICPC is launching a thick burger. The thickness (or the height) of a piece of club steak is A (1 ≤ A ≤ 100). The thickness (or the height) of a piece of chicken steak is B (1 ≤ B ≤ 100).
The chef allows to add just three pieces of meat into the burger and he does not allow to add three pieces of same type of meat. As a customer and a foodie, you want to know the maximum total thickness of a burger which you can get from the chef. Here we ignore the thickness of breads, vegetables and other seasonings.

Input
The first line is the number of test cases. For each test case, a line contains two positive integers A and B.

Output
For each test case, output a line containing the maximum total thickness of a burger.

Sample Input
10
68 42
1 35
25 70
59 79
65 63
46 6
28 82
92 62
43 96
37 28

Sample Output
178
71
165
217
193
98
192
246
235
102

Hint
Consider the first test case, since 68+68+42 is bigger than 68+42+42 the answer should be 68+68+42 = 178.
Similarly since 1+35+35 is bigger than 1+1+35, the answer of the second test case should be 1+35+35 = 71.

大致题意:
第一行一个数表示 t 组,接下来每行两个数,求(大数*2)+(小数)的和

思路
水题,思路不说了

代码

#include<bits/stdc++.h>
using namespace std;
typedef long long int LLD;
int main()
{
    LLD t;
    scanf("%lld",&t);
    while (t--)
    {
        LLD a,b;
        scanf("%lld %lld",&a,&b);
        if (a>b)
        {
            printf("%lld\n",a+a+b);
        }else
        {
             printf("%lld\n",a+b+b);
        }
    }
    return 0;
}
发布了27 篇原创文章 · 获赞 4 · 访问量 4417

猜你喜欢

转载自blog.csdn.net/qq_43735840/article/details/104347900