poj 1509 Glass Beads

Glass Beads
Time Limit: 3000MS   Memory Limit: 10000K
Total Submissions: 4868   Accepted: 2749

Description

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace. 

The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads. 

The description of the necklace is a string A = a1a2 ... am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion. 

The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 ... ana1 ... ai-1 is lexicografically smaller than the string ajaj+1 ... ana1 ... aj-1. String a1a2 ... an is lexicografically smaller than the string b1b2 ... bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a--z), where a < b ... z.

Output

For each case, print exactly one line containing only one integer -- number of the bead which is the first at the worst possible disjoining, i.e.\ such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

Sample Input

4
helloworld
amandamanda
dontcallmebfu
aaabaaa

Sample Output

10
11
6
5

题意:
把字符串链从某一点剖开,使得剖开后的字符串的字典序最小,求从哪里剖开。
思路:设原先字符串s,可以把字符串s复制一份放到s末尾,即s=s+s,这样不管你从链子的哪里剖开,剖开后的字符串一定能在新的s的后缀当中找到,这样只要求出后缀数组即可。要注意字符串所有字母一样的情况,
如果我们事先在新的s的末尾添上一个比所有字母都大的字符再求后缀数组即可。
AC代码:
Source Code

Problem: 1509        User: ach11090913
Memory: 496K        Time: 94MS
Language: C++        Result: Accepted
Source Code
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
const int INF = 0x3f3f3f3f;
const int N_MAX = 10000 + 20;
typedef long long ll;
int n, k;
int Rank[N_MAX*2];
int tmp[N_MAX*2];
int sa[N_MAX * 2];
bool compare_sa(int i,int j) {
    if (Rank[i] != Rank[j])return Rank[i] < Rank[j];
    else {
        int ri = i + k <= n ? Rank[i + k] : -1;
        int rj = j + k <= n ? Rank[j + k] : -1;
        return ri < rj;
    }
}

void construct_sa(string S,int *sa) {
    n = S.size();
    for (int i = 0; i <= n;i++) {
        sa[i] = i;
        Rank[i] = i < n ? S[i] : -1;
    }
    for (k = 1; k <= n;k*=2) {
        sort(sa,sa+n+1,compare_sa);
        tmp[sa[0]] = 0;
        for (int i = 1; i <= n;i++) {
            tmp[sa[i]] = tmp[sa[i - 1]] + (compare_sa(sa[i - 1], sa[i]) ? 1 : 0);
        }
        for (int i = 0; i <= n;i++) {
            Rank[i] = tmp[i];
        }
    }
}

int main() {
    int N; cin >> N;
    while (N--) {
         string s;
         cin >> s; int sz = s.size();
        s =s+ s+(char)('z'+1);//预防所有字符一样的情况
        construct_sa(s, sa);
        for (int i = 0; i <= s.size();i++) {
            if ( sa[i] < sz) {
                printf("%d\n",sa[i]+1);
                break;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/ZefengYao/p/9064271.html