PAT 甲级 1103 Integer Factorization(DFS)

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + … n[K]^P

where n[i] (i = 1, …, K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122​+4​2+2​2+2​2+1​2or 11​2​+6​2+2​2+2​2+2​2
​​ , or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen – sequence { a​1​​ ,a​2​​ ,⋯,a​K​​} is said to be larger than { b​1​​ ,b​2​​ ,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​ =b​i​​ for i<L and a​L​​ >b​L​​ .

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

解题思路:本题是对基础的DFS算法的运用,题目中要求取得底数和最大的序列,如果底数总和一样大,比较字典序,所以将index从大到小开始遍历。本题一开始先把能够取到的底数存在数组a中,因为每个底数能够重复取得,要注意递归时DFS里的参数的使用。temp暂存所用到的底数,ans存目前最符合要求的底数。

代码:

#include<cstdio>
#include<vector>
#include<math.h>
using namespace std;
int K,N,P,a[100];
int sum = 0,suma = 0;
int maxnum = -1;
vector<int> temp,ans;
void setnum()
{
	while((int)pow(suma,P) <= N)
	{
	 	a[suma] = (int)pow(suma,P);
	 	suma++;
	}
}
void DFS(int index,int sumN,int sumK,int sumnum)  //sumN存总和,sumK存使用的底数的数量,sunnum存储底数的和 
{
	if(sumN == N&&sumK == K)
	{
		if(sumnum > maxnum)
		{
			maxnum = sumnum;
			ans = temp;
		}
		return;
	}
	if(index < 1||sumN > N||sumK > K) return;
	temp.push_back(index); //取index 
	DFS(index,sumN + a[index],sumK+1,sumnum + index); //因为底数可以重复取得所以这里index不变 
	temp.pop_back();
	DFS(index - 1,sumN,sumK,sumnum); //不取index 
}
int main(void)
{
	scanf("%d %d %d",&N,&K,&P);
	setnum();
	DFS(suma - 1,0,0,0);
	if(maxnum == -1)
		printf("Impossible");
	else
		{
			printf("%d = %d^%d",N,ans[0],P);
			for(int i = 1;i < ans.size();i++)
				printf(" + %d^%d",ans[i],P);
		}
	return 0;
}
发布了24 篇原创文章 · 获赞 1 · 访问量 501

猜你喜欢

转载自blog.csdn.net/lovingcgq/article/details/104418025
今日推荐