[COCI2006-2007#2] ABC

题目描述

You will be given three integers A, B and C. The numbers will not be given in that exact order, but we do know that A is less than B and B less than C. In order to make for a more pleasant viewing, we want to rearrange them in the given order.

输入输出格式

输入格式:

The first line contains three positive integers A, B and C, not necessarily in that order. All three numbers will be less than or equal to 100. The second line contains three uppercase letters 'A', 'B' and 'C' (with no spaces between them) representing the desired order.

输出格式:

Output the A, B and C in the desired order on a single line, separated by single spaces.

输入输出样例

输入样例#1:

1 5 3
ABC

输出样例#1:

1 3 5

输入样例#2:

6 4 2
CAB

输出样例#2:

6 2 4

用Python做就没啥好解释的了

#!/usr/bin/env python
# -*- coding: utf-8 -*-
dic = {}
n = input().split()
#print(n)
l = len(n)

for i in range(0, l):    #转换为整数,莫得大意
    n[i] = int(n[i])
n.sort()
dic['A'] = n[0]
dic['B'] = n[1]
dic['C'] = n[2]
s = input()
s = s[:-1]  
for i in s:
    print(dic[i], end=' ')

又用到了字典

所以为什么要s=s[:-1]呢?请见https://blog.csdn.net/baidu_41248654/article/details/96143280

发布了58 篇原创文章 · 获赞 40 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/baidu_41248654/article/details/96164287
ABC