[COCI2006-2007#2] R2

click here to luogu.org

题目描述

The number S is called the mean of two numbers R1 and R2 if S is equal to (R1+R2)/2. Mirko's birthday present for Slavko was two integers R1 and R2. Slavko promptly calculated their mean which also happened to be an integer but then lost R2! Help Slavko restore R2.

输入输出格式

输入格式:

The first and only line of input contains two integers R1 and S, both between -1000 and 1000.

输出格式:

Output R2 on a single line.

输入输出样例

输入样例#1:   11 15

输出样例#1:   19

输入样例#2:   4 3

输出样例#2:   2

c++

#include<iostream>
using namespace std;
int main()
{
	int r1,r2,s;
	cin>>r1>>s;
	r2=s*2-r1;
	cout<<r2;
	return 0;
}

Python

# -*- coding: utf-8 -*-
num = input().split()
r1 = num[0]
s = num[1]
r2 = int(s)*2 - int(r1)
print(r2)

猜你喜欢

转载自blog.csdn.net/baidu_41248654/article/details/93197949