HDU-2057 A + B Again(16进制的计算)

Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input

The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output

For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input

+A -A

+1A 12

1A -9

-1A -12

1A -AA

Sample Output

0

2C

11

-2C

-90

o 以八进制形式输出无符号整数(不输出前缀O) 
x   以十六进制形式输出无符号整数(不输出前缀OX) 

代码:

#include <stdio.h>

int main()
{
	long long a,b,sum;
	while(scanf("%llx%llx",&a,&b)!=EOF)
	{
		sum=a+b;
		if(sum>=0)
			printf("%llX\n",sum);
		else
			printf("-%llX\n",-sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/81945214