Majority ICPC_Pacific Northwest Region Programming Contest基础题

Problem N

— limit 5 seconds

The votes are in! Mathematicians world-wide have been polled, and each has chosen their favorite number between 1 and 1000. Your goal is to tally the votes and determine what the most popular number is.
If there is a tie for the greatest number of votes, choose the smallest number with that many votes.
Input
Input will start with a single line containing the number of test cases, between 1 and 100 inclusive. For each test case, there will be a single line giving the number of votes V , 1 ≤ V ≤ 1000. Following that line will be V lines, each with a single integer vote between 1 and 1000.
Output
Sample Input Sample Output
3 42 37 42 11 42
19
4
7
99
99
7
5
11
12
13
14
15
2014 Pacific Northwest Region Programming Contest—Division 2 5

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
void acc()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
}
int a[1210];
int main()
{
    acc();
    int t;
    cin>>t;
    while(t--)
    {
        int ans =  0, mtime = -1;
        memset(a, 0, sizeof(a));
        int n;
        cin>>n;
        while(n--)
        {
            int x;
            cin >> x;
            a[x]++;
            if(a[x] > mtime)
            {
                ans = x;
                mtime = a[x];
            }
            else if(a[x] == mtime && x < ans)
            {
                ans = x;
            }
        }
        cout<<ans<<endl;
    }
    return  0;
}

发布了340 篇原创文章 · 获赞 128 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/king9666/article/details/104167045