ACM第六届山东省赛 J-Single Round Math

J-Single Round Math

Time Limit: 1000 ms   Memory Limit: 65536 KiB

Problem Description
Association for Couples Math (ACM) is a non-profit organization which is engaged in helping single people to find his/her other half. As November 11th is “Single Day”, on this day, ACM invites a large group of singles to the party. People round together, chatting with others, and matching partners.
There are N gentlemen and M ladies in the party, each gentleman should only match with a lady and vice versa. To memorize the Singles Day, ACM decides to divides to divide people into 11 groups, each group should have the same amount of couples and no people are left without the groups.
Can ACM achieve the goal?

Input
The first line of the input is a positive integer T. T is the number of test cases followed. Each test case contains two integer N and M (0 ≤ N, M ≤ 10^1000), which are the amount of gentlemen and ladies.

Output
For each test case, output “YES” if it is possible to find a way, output “NO” if not.

Sample Input
3
1 1
11 11
22 11

Sample Output
NO
YES
NO

题目链接:http://acm.sdut.edu.cn/onlinejudge2/index.php/Home/Index/problemdetail/pid/3260.html

本题的题意:判断gentlemen的数量N与ladies的数量M是否相等并且能整除以11,若能则输出YES,否则输出NO

参考代码

思路一:直接用Java大数类

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        int t;
        Scanner scanner = new Scanner(System.in);
        BigInteger nBigInteger = null;
        BigInteger mBigInteger = null;
        t = scanner.nextInt();
        while(t-- != 0) {
            nBigInteger = scanner.nextBigInteger();
            mBigInteger = scanner.nextBigInteger();
            if(nBigInteger.compareTo(mBigInteger) == 0 && nBigInteger.mod(new BigInteger("11")).compareTo(new BigInteger("0")) == 0)
                System.out.println("YES");
            else
                System.out.println("NO");
        }
    }

}

思路二:转换的时候每次都对11取余

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define N 100010
using namespace std;
char n[N];
char m[N];
int main()
{
    int t;
    int i, j, k;
    int sum = 0;
    scanf("%d", &t);
    while(t--){
        scanf("%s %s", n, m);
        if(strcmp(n, m) != 0)
            printf("NO\n");
        else{
            sum=0;
            for(i = 0; i < strlen(n); i++)
                sum = (sum*10+n[i]-'0')%11;
            if(sum==0)
                printf("YES\n");
            else
                printf("NO\n");
        }
    }
    return 0;
}

思路三:一个数的奇数位数字和与偶数位数字和之间的差能被11整除,那这个数就能被11整除

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define N 100010
using namespace std;
char n[N];
char m[N];
int main()
{
    int t;
    int i, j, k;
    int sum = 0;
    scanf("%d", &t);
    while(t--){
        scanf("%s %s", n, m);
        if(strcmp(n, m) != 0)
            printf("NO\n");
        else{
            sum=0;
            for(i = 0; i < strlen(n); i++){
                if(i%2)
                    sum += n[i]-'0';
                else
                    sum -= n[i]-'0';
            }
            if(sum%11 == 0)
                printf("YES\n");
            else
                printf("NO\n");
        }
    }
    return 0;
}
发布了118 篇原创文章 · 获赞 479 · 访问量 21万+

猜你喜欢

转载自blog.csdn.net/y_universe/article/details/79934428