Unhappy Hacking I

问题 J: Unhappy Hacking I

时间限制: 1 Sec  内存限制: 128 MB
提交: 174  解决: 78
[提交][状态][讨论版][命题人:admin]

题目描述

Sig has built his own keyboard. Designed for ultimate simplicity, this keyboard only has 3 keys on it: the 0 key, the 1 key and the backspace key.
To begin with, he is using a plain text editor with this keyboard. This editor always displays one string (possibly empty). Just after the editor is launched, this string is empty. When each key on the keyboard is pressed, the following changes occur to the string:
  The 0 key: a letter 0 will be inserted to the right of the string.
  The 1 key: a letter 1 will be inserted to the right of the string.
  The backspace key: if the string is empty, nothing happens. Otherwise, the rightmost letter of the string is deleted.
Sig has launched the editor, and pressed these keys several times. You are given a string s, which is a record of his keystrokes in order. In this string, the letter 0 stands for the 0 key, the letter 1 stands for the 1 key and the letter B stands for the backspace key. What string is displayed in the editor now?

Constraints
1≤|s|≤10 (|s| denotes the length of s)
s consists of the letters 0, 1 and B.
The correct answer is not an empty string.

输入

The input is given from Standard Input in the following format:
s

输出

Print the string displayed in the editor in the end.

样例输入

01B0

样例输出

00

提示

Each time the key is pressed, the string in the editor will change as follows: 0, 01, 0, 00.

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
 
int main()
{
    char str[105];
    scanf("%s",str);
    int n = strlen(str);
    int index = 0;
    int b[105];
    for(int i=0;i<105;i++)
    {
        b[i] = -1;
    }
    for(int i=0;i<n;i++)
    {
        if(str[i]=='0'||str[i]=='1')
        {
            b[index] = str[i]-'0';
            index++;
        }
        else if(str[i]=='B')
        {
            if(index>0)
            {
                 index--;
                b[index] = -1;
            }
           else
            continue;
             
        }
    }
    for(int i=0;i<index;i++)
    {
        printf("%d",b[i]);
    }
}
 

猜你喜欢

转载自www.cnblogs.com/hao-tian/p/9054368.html