DP专题----C - Monkey and Banana (最长递增子序列)

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题中提到可无限取,还以为是完全背包,感觉自己是傻子,但是每个木块,分为6种情况,每个情况最多取一次,这就不存在无限取了,然后排序一下,跑O(n^2)的最长严格递增子序列即可

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define mp make_paie
#define pb push_back
#define fi first
#define se second

typedef struct Node{
    int x,y,z;
    friend bool operator < (const Node &p,const Node &q){
        if(p.x == q.x){
            return p.y < q.y;
        }else{
            return p.x < q.x;
        }
    }
}Node;
Node node[205];

int dp[205];

int main()
{
    int n;
    int t = 0;
    while(~scanf("%d",&n)){
        if(n == 0) break;
        int cnt = 0;
        for(int i = 1;i <= n;++i){
            int a,b,c;
            scanf("%d %d %d",&a,&b,&c);
            node[cnt++] = (Node){a,b,c};
            //cout << node[cnt - 1].x << " " << node[cnt - 1].y << " " << node[cnt - 1].z << endl;
            node[cnt++] = (Node){b,a,c};
            //cout << node[cnt - 1].x << " " << node[cnt - 1].y << " " << node[cnt - 1].z << endl;
            node[cnt++] = (Node){a,c,b};
           // cout << node[cnt - 1].x << " " << node[cnt - 1].y << " " << node[cnt - 1].z << endl;
            node[cnt++] = (Node){c,a,b};
            //cout << node[cnt - 1].x << " " << node[cnt - 1].y << " " << node[cnt - 1].z << endl;
            node[cnt++] = (Node){b,c,a};
            //cout << node[cnt - 1].x << " " << node[cnt - 1].y << " " << node[cnt - 1].z << endl;
            node[cnt++] = (Node){c,b,a};
            //cout << node[cnt - 1].x << " " << node[cnt - 1].y << " " << node[cnt - 1].z << endl;
        }
        sort(node,node + cnt);
        int MAX = -1;
        memset(dp,0,sizeof(dp));
        for(int i = 0;i < cnt;++i){
            dp[i] = node[i].z;
            for(int j = 0;j < i;++j){
                if((node[j].x < node[i].x) && (node[j].y < node[i].y)){
                    //cout << i << " " << j << endl;
                    dp[i] = max(dp[i],dp[j] + node[i].z);
                }
            }
            if(dp[i] > MAX){
                MAX = dp[i];
            }
        }
        printf("Case %d: maximum height = %d\n",++t,MAX);
    }
    return 0;
}


发布了269 篇原创文章 · 获赞 33 · 访问量 8万+

猜你喜欢

转载自blog.csdn.net/qq_36386435/article/details/88938189