POJ2502 Subway 最短路

一、内容

You have just moved from a quiet Waterloo neighbourhood to a big, noisy city. Instead of getting to ride your bike to school every day, you now get to walk and take the subway. Because you don't want to be late for class, you want to know how long it will take you to get to school.
You walk at a speed of 10 km/h. The subway travels at 40 km/h. Assume that you are lucky, and whenever you arrive at a subway station, a train is there that you can board immediately. You may get on and off the subway any number of times, and you may switch between different subway lines if you wish. All subway lines go in both directions. 

Input.

Input consists of the x,y coordinates of your home and your school, followed by specifications of several subway lines. Each subway line consists of the non-negative integer x,y coordinates of each stop on the line, in order. You may assume the subway runs in a straight line between adjacent stops, and the coordinates represent an integral number of metres. Each line has at least two stops. The end of each subway line is followed by the dummy coordinate pair -1,-1. In total there are at most 200 subway stops in the city. 

Output

Output is the number of minutes it will take you to get to school, rounded to the nearest minute, taking the fastest route. 

Sample Input

0 0 10000 1000
0 200 5000 200 7000 200 -1 -1 
2000 600 5000 600 10000 600 -1 -1

Sample Output

21

二、思路

  • 给起点编号为0,终点编号为201(因为最多200个站台)。从起点到所有站台,所有站台到终点都建立一条步行的边。两两站台之间也要建立一条步行的边
  • 然后就是一条航线中的相邻站台建立一条40km/h的花费的边。
  • 题目给出的坐标算出来的距离单位是m, 给出的速度是km/h。
  • 答案输出应该四舍五入。 有点坑。 int(d + 0.5)

三、代码

#include <cstdio>
#include <cmath>
#include <iostream>
#include <cstring>
#include <queue> 
using namespace std;
const int N = 205, M = 5e4 + 5;
struct E {
	int v, next;
	double w;
} e[M];
struct Stop {
	int x, y;
} stop[N];
int id = 1, x, y, lx, ly, sx, sy, ex, ey, len = 1, h[N];//id代表点的标号 
bool vis[N]; //起点是0 终点的编号是201 因为最多有200个站点 
double d[N];
double getD(int x1, int y1, int x2, int y2, int t) {
	double x = x1 - x2;
	double y = y1 - y2;
	return sqrt(x*x + y*y) / t / 1000 * 60; 
}
void add(int u, int v, double w) {
	e[len].v = v;
	e[len].w = w;
	e[len].next = h[u];
	h[u] = len++;
}
//若a > b 返回true a <= b 返回false 
bool cmp(double a, double b) {
	if (a - b > 1e-4) return true;
	return false;
}
void spfa() {
    for (int i = 1; i < id; i++) d[i] = 1e18; 
	d[0] = 0; d[201] = 1e18;
	queue<int> q;
	q.push(0);
	while (!q.empty()) {
		int u = q.front();
		q.pop();
		vis[u] = false;
		for (int j = h[u]; j; j = e[j].next) {
			int v = e[j].v;
			double w = d[u] + e[j].w;
			if (cmp(d[v], w)) {
				d[v] = w;
				if (!vis[v]) q.push(v), vis[v] = true;
			} 
		}
	}
}
int main() {
	scanf("%d%d%d%d", &sx, &sy, &ex, &ey);
	while (~scanf("%d%d", &stop[id].x, &stop[id].y)) {
		x = stop[id].x, y = stop[id].y;
		add(0, id, getD(x, y, sx, sy, 10));
		add(id, 201, getD(x, y, ex, ey, 10));
		++id; 
		while (scanf("%d%d", &stop[id].x, &stop[id].y), stop[id].x != -1) {
			x = stop[id].x, y = stop[id].y;
			lx = stop[id - 1].x, ly = stop[id - 1].y;
			//从站点步行到终点 和起点 
			add(0, id, getD(x, y, sx, sy, 10));
			add(id, 201, getD(x, y, ex, ey, 10)); 
			//建立与前一个站点的边
			add(id, id - 1, getD(x, y, lx, ly, 40)); 
			add(id - 1, id, getD(x, y, lx, ly, 40));
	 		++id; //-1的时候id不变 
		} 
	}
	//每个站台之间可以步行  总共的标号是【1, id-1】 
	for (int i = 1; i < id; i++) {
		for (int j = i + 1; j < id; j++) {
			x = stop[i].x, y = stop[i].y;
			lx = stop[j].x, ly = stop[j].y;
			add(i, j, getD(x, y, lx, ly, 10));
			add(j, i, getD(x, y, lx, ly, 10));
		}
	}
	spfa();
	printf("%d", int(d[201] + 0.5));//四舍五入 
	return 0;
}
发布了414 篇原创文章 · 获赞 380 · 访问量 6万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/104196333