优先队列——The kth great number

The kth great number

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a “Q”, then you need to output the kth great number.
Output
The output consists of one integer representing the largest number of islands that all lie on one line.
Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
Sample Output
1
2
3

////自己一开始思路:输出时pop掉前面k-1个加到后面:错误
////题意:第k个大数,让q从小到大一直保持有k个,那么第一个也就是第k个大数
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector> //可有可无
#include<queue>
#include<functional> //!!!!不能忘,否则会:未声明的标识符错误
using namespace std;
typedef unsigned long long ll;
int main(){
    int n,k,a;
    char op;
    while(cin >> n >> k){
        priority_queue <int,vector<int>,greater<int> > q;
        while(n--){
            cin >> op;
            if(op=='I'){
                cin >> a;
                q.push(a);
                if(q.size()>k)
                    q.pop();
            }
            if(op=='Q'){
                cout << q.top() << endl;
            }
        }
    }
    return 0;
}
发布了30 篇原创文章 · 获赞 0 · 访问量 669

猜你喜欢

转载自blog.csdn.net/jhckii/article/details/104176233
今日推荐