【UVA 253 --- Cube painting】

【UVA 253 --- Cube painting】

题目来源:点击进入【UVA 253 — Cube painting】

Description

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a
string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the
remaining 6 characters give you the representation of another cube. Your program determines whether
these two cubes are painted in the same way, that is, whether by any combination of rotations one can
be turned into the other. (Reflections are not allowed.)

Output

The output is a file of boolean. For each line of input, output contains ‘TRUE’ if the second half can be
obtained from the first half by rotation as describes above, ‘FALSE’ otherwise.

Sample Input

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

Sample Output

TRUE
FALSE
FALSE

解题思路

根据题意我们只需判断正方体的三个互相垂直的面以及与其相对的那个面在另外一个正方形中是否能找到即可。当然找到过的需要去掉。

AC代码:

#include <stdio.h>
char s[15],s1[8],s2[8];

int main()
{
    while(~scanf("%s",s))
    {
        for(int i=0;i<6;i++)
            s1[i]=s[i],s2[i]=s[i+6];
        bool flag=false;
        for(int i=0;i<3;i++)
        {
            flag=false;
            for(int j=0;j<6;j++)
            {
                if(s1[i]!=s2[j] || s1[5-i]!=s2[5-j]) continue;
                flag=true;
                s2[j]=s2[5-j]='#';
                break;
            }
            if(!flag) break;
        }
        if(flag) printf("TRUE\n");
        else printf("FALSE\n");
    }
    return 0;
}
发布了412 篇原创文章 · 获赞 135 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_41879343/article/details/104263176