UVA 11728 - Alternate Task (因子和)

Description:

Little Hasan loves to play number games with his friends. One day they were playing a game where
one of them will speak out a positive number and the others have to tell the sum of its factors. The
first one to say it correctly wins. After a while they got bored and wanted to try out a different game.
Hassan then suggested about trying the reverse. That is, given a positive number S S , they have to find
a number whose factors add up to S S . Realizing that this task is tougher than the original task, Hasan
came to you for help. Luckily Hasan owns a portable programmable device and you have decided to
burn a program to this device. Given the value of S S as input to the program, it will output a number
whose sum of factors equal to S S .

Input

Each case of input will consist of a positive integer S 1000 S ≤ 1000 . The last case is followed by a value of
0 ‘0’ .

Output

For each case of input, there will be one line of output. It will be a positive integer whose sum of
factors is equal to S S . If there is more than one such integer, output the largest. If no such number
exists, output 1 ‘-1’ . Adhere to the format shown in sample output.

Sample Input

1
102
1000
0

Sample Output

Case 1: 1
Case 2: 101
Case 3: -1

题意:

给你一个 S S , 问你 n n 的因子数的和 为 S S ,求 n n
S S 很小,求出 n n 的因子和 S S , 数组取反就好了。

AC代码:

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <stack>
#include <queue>
using namespace std;
#define sd(n) scanf("%d", &n)
#define sdd(n, m) scanf("%d%d", &n, &m)
#define sddd(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define pd(n) printf("%d\n", n)
#define pc(n) printf("%c", n)
#define pdd(n, m) printf("%d %d\n", n, m)
#define pld(n) printf("%lld\n", n)
#define pldd(n, m) printf("%lld %lld\n", n, m)
#define sld(n) scanf("%lld", &n)
#define sldd(n, m) scanf("%lld%lld", &n, &m)
#define slddd(n, m, k) scanf("%lld%lld%lld", &n, &m, &k)
#define sf(n) scanf("%lf", &n)
#define sc(n) scanf("%c", &n)
#define sff(n, m) scanf("%lf%lf", &n, &m)
#define sfff(n, m, k) scanf("%lf%lf%lf", &n, &m, &k)
#define ss(str) scanf("%s", str)
#define rep(i, a, n) for (int i = a; i <= n; i++)
#define per(i, a, n) for (int i = n; i >= a; i--)
#define mem(a, n) memset(a, n, sizeof(a))
#define debug(x) cout << #x << ": " << x << endl
#define pb push_back
#define all(x) (x).begin(), (x).end()
#define fi first
#define se second
#define mod(x) ((x) % MOD)
#define gcd(a, b) __gcd(a, b)
#define lowbit(x) (x & -x)
typedef pair<int, int> PII;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const int MOD = 1e9 + 7;
const double eps = 1e-9;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const int inf = 0x3f3f3f3f;
inline int read()
{
	int ret = 0, sgn = 1;
	char ch = getchar();
	while (ch < '0' || ch > '9')
	{
		if (ch == '-')
			sgn = -1;
		ch = getchar();
	}
	while (ch >= '0' && ch <= '9')
	{
		ret = ret * 10 + ch - '0';
		ch = getchar();
	}
	return ret * sgn;
}
inline void Out(int a) //Êä³öÍâ¹Ò
{
	if (a > 9)
		Out(a / 10);
	putchar(a % 10 + '0');
}

ll gcd(ll a, ll b)
{
	return b == 0 ? a : gcd(b, a % b);
}

ll lcm(ll a, ll b)
{
	return a * b / gcd(a, b);
}
///快速幂m^k%mod
ll qpow(ll a, ll b, ll mod)
{
	if (a >= mod)
		a = a % mod + mod;
	ll ans = 1;
	while (b)
	{
		if (b & 1)
		{
			ans = ans * a;
			if (ans >= mod)
				ans = ans % mod + mod;
		}
		a *= a;
		if (a >= mod)
			a = a % mod + mod;
		b >>= 1;
	}
	return ans;
}

// 快速幂求逆元
int Fermat(int a, int p) //费马求a关于b的逆元
{
	return qpow(a, p - 2, p);
}

///扩展欧几里得
int exgcd(int a, int b, int &x, int &y)
{
	if (b == 0)
	{
		x = 1;
		y = 0;
		return a;
	}
	int g = exgcd(b, a % b, x, y);
	int t = x;
	x = y;
	y = t - a / b * y;
	return g;
}

///使用ecgcd求a的逆元x
int mod_reverse(int a, int p)
{
	int d, x, y;
	d = exgcd(a, p, x, y);
	if (d == 1)
		return (x % p + p) % p;
	else
		return -1;
}

///中国剩余定理模板0
ll china(int a[], int b[], int n) //a[]为除数,b[]为余数
{
	int M = 1, y, x = 0;
	for (int i = 0; i < n; ++i) //算出它们累乘的结果
		M *= a[i];
	for (int i = 0; i < n; ++i)
	{
		int w = M / a[i];
		int tx = 0;
		int t = exgcd(w, a[i], tx, y); //计算逆元
		x = (x + w * (b[i] / t) * x) % M;
	}
	return (x + M) % M;
}

const int N = 1000;
int ans[N + 10], b[N + 10];
void init()
{
	mem(a, -1);
	rep(i, 1, N)
	{
		for (int j = i; j <= N; j += i)
		{
			b[j] += i;
		}
		if (b[i] < N)
			a[b[i]] = i;
	}
}
int main()
{
	init();
	int cas = 1, n;
	while (~sd(n) && n)
	{
		printf("Case %d: %d\n", cas++, ans[n]);
	}
	return 0;
}
发布了631 篇原创文章 · 获赞 399 · 访问量 20万+

猜你喜欢

转载自blog.csdn.net/qq_43627087/article/details/104186606
今日推荐