数据结构与算法题目集 7-22 堆栈模拟队列

7-22 堆栈模拟队列 (25分)

设已知有两个堆栈S1和S2,请用这两个堆栈模拟出一个队列Q。

所谓用堆栈模拟队列,实际上就是通过调用堆栈的下列操作函数:

  • int IsFull(Stack S):判断堆栈S是否已满,返回1或0;
  • int IsEmpty (Stack S ):判断堆栈S是否为空,返回1或0;
  • void Push(Stack S, ElementType item ):将元素item压入堆栈S
  • ElementType Pop(Stack S ):删除并返回S的栈顶元素。

实现队列的操作,即入队void AddQ(ElementType item)和出队ElementType DeleteQ()

输入格式:

输入首先给出两个正整数N1N2,表示堆栈S1S2的最大容量。随后给出一系列的队列操作:A item表示将item入列(这里假设item为整型数字);D表示出队操作;T表示输入结束。

输出格式:

对输入中的每个D操作,输出相应出队的数字,或者错误信息ERROR:Empty。如果入队操作无法执行,也需要输出ERROR:Full。每个输出占1行。

输入样例:

3 2
A 1 A 2 A 3 A 4 A 5 D A 6 D A 7 D A 8 D D D D T

输出样例:

ERROR:Full
1
ERROR:Full
2
3
4
7
8
ERROR:Empty

题解: 

#include <bits/stdc++.h>
using namespace std;

int n, m;
stack<int> a, b;

inline const int read()
{
    int x = 0, f = 1; char ch = getchar();
    while (ch < '0' || ch > '9') { if (ch == '-') f = -1; ch = getchar(); }
    while (ch >= '0' && ch <= '9') { x = (x << 3) + (x << 1) + ch - '0'; ch = getchar(); }
    return x * f;
}

void push()
{
    int x = read();
    if (a.size() == n && !b.empty()) printf("ERROR:Full\n");
    else if (a.size() == n)
    {
        while (!a.empty())
        {
            b.push(a.top());
            a.pop();
        }
        a.push(x);
    }
    else a.push(x);
}

void pop()
{
    if (a.empty() && b.empty()) printf("ERROR:Empty\n");
    else if (b.empty())
    {
        while (!a.empty())
        {
            b.push(a.top());
            a.pop();
        }
        printf("%d\n", b.top());
        b.pop();
    }
    else
    {
        printf("%d\n", b.top());
        b.pop();
    }
}

int main()
{
    n = read(); m = read();
    if (n > m) swap(n, m);
    string s;
    while (cin >> s && s != "T") s == "A" ? push() : pop();
    return 0;
}
发布了367 篇原创文章 · 获赞 148 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_35850147/article/details/103574528