PAT甲级1086

1086 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

本题用栈的形式模拟二叉树的先序和中序遍历,Push就是先序过程,Pop就是中序过程,通过先序和中序遍历构造二叉树,最后层序遍历输出

#include<iostream>
#include<algorithm>
#include<string.h>
#include<stack>
using namespace std;

struct Node{
	int data;
	Node* lchild;
	Node* rchild;
};
int n, prelist[40], inlist[40], postlist[40], num = 0;

Node* create(int prel, int prer, int inl, int inr){
	if (prel>prer)
		return NULL;
	Node* root = new Node;
	root->data = prelist[prel];
	int index;
	for (index = inl; index <= inr;index++)
	if (inlist[index] == prelist[prel])
		break;
	int numl = index - inl;
	root->lchild = create(prel + 1, prel + numl, inl, index - 1);
	root->rchild = create(prel + numl + 1, prer, index + 1, inr);
	return root;
}

void postorder(Node* root){
	if (root == NULL)
		return;
	postorder(root->lchild);
	postorder(root->rchild);
	postlist[num] = root->data;
	num++;
}

int main(){
	scanf("%d", &n);
	stack<int> st;
	char str[5];
	int push = 0, pop = 0, x;
	for (int i = 0; i < n * 2; i++){
		scanf("%s", &str);
		if (strcmp(str, "Push") == 0){
			scanf("%d", &x);
			st.push(x);
			prelist[push] = x;
			push++;
		}
		else{
			inlist[pop] = st.top();
			st.pop();
			pop++;
		}
	}
	Node* root = create(0, n - 1, 0, n - 1);
	postorder(root);
	for (int i = 0; i < n; i++)
	if (i != n - 1)
		printf("%d ", postlist[i]);
	else
		printf("%d", postlist[i]);
	return 0;
}
发布了116 篇原创文章 · 获赞 7 · 访问量 6050

猜你喜欢

转载自blog.csdn.net/qq_40204582/article/details/86768263