codeup 1918: 简单计算器

题目:http://codeup.cn/problem.php?id=1918

题目描述

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

输入

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

输出

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

样例输入

30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0

样例输出

12178.21

 1、getline(cin, str) 可读入空格,以换行为结束标志。

2、队列的应用。

3、中缀表达式后缀表达式,后缀表达式的计算。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<stack>
#include<queue>
#include<map> 
using namespace std;

struct node
{
	double num;
	char op;
	bool flag; //true: 操作数  false: 操作符 
};

string str;
stack<node> symbol; //操作符栈 
queue<node> postfix;  //后缀表达式序列
map<char,int> op; //存放优先级 

//将中缀表达式转换为后缀表达式 
void change()
{
	//double num;
	node temp; //临时结点! 
	for(int i=0;i<str.length();)
	{
		if(str[i]>='0'&&str[i]<='9')
		{
			temp.flag=true;
			temp.num=str[i++]-'0';
			while(i<str.length()&&str[i]>='0'&&str[i]<='9')
			{
				temp.num=temp.num*10+(str[i++]-'0');
				//i++;
			} 
			postfix.push(temp);
		}
		else
		{
			temp.flag=false;
			while(!symbol.empty()&&op[str[i]]<=op[symbol.top().op])
			{
				postfix.push(symbol.top());
				symbol.pop();
			}
			temp.op=str[i];
			symbol.push(temp);
			i++;
		}		
	}	 
	
	//操作符栈中还有操作符
	while(!symbol.empty())
	{
		postfix.push(symbol.top());
		symbol.pop();
	} 
} 
 
double cal()
{
	double temp1,temp2;
	node cur,temp;
	while(!postfix.empty())
	{
		cur=postfix.front();
		postfix.pop();
		
		if(cur.flag==true) symbol.push(cur);  //符号栈重用,【注】存操作数。 
		else
		{
			temp2=symbol.top().num;
			symbol.pop();
			temp1=symbol.top().num;
			symbol.pop();
			
			temp.flag=true;
			if(cur.op=='+') temp.num=temp1+temp2;
			else if(cur.op=='-') temp.num=temp1-temp2;
			else if(cur.op=='*') temp.num=temp1*temp2;
			else temp.num=temp1/temp2;
			
			symbol.push(temp); 
		}		
	}
	return symbol.top().num;
}

int main()
{
	//利用map设置优先级  
	op['+']=op['-']=1;
	op['*']=op['/']=2;
	while(getline(cin,str),str!="0") //cin>>str
	{
		//去掉空格 
		for(string::iterator it=str.begin();it!=str.end();it++)
		{
			if(*it==' ') str.erase(it);
		}
		//清空符号栈 
		while(!symbol.empty()) symbol.pop();
		
		change();
		printf("%.2f\n",cal());
	} 
	return 0;
} 
发布了180 篇原创文章 · 获赞 64 · 访问量 15万+

猜你喜欢

转载自blog.csdn.net/OpenStack_/article/details/103982035