PAT甲组 1022. Digital Library (30)

1022. Digital Library (30)

时间限制
1000 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题意:有N本书,每本书有六行信息,分别是七位ID号,书名,作者,关键字(可以有多个,可以考虑用stream来进行分割),出版社,出版年份。M个查询,给出一个编号,代表除ID外的一条信息,要输出所有满足该信息的书的ID。

思路:用stream来解决未知的一行多个关键字问题。考虑用<string,set<int>>来构建某个信息和所有满足该信息ID的映射,美滋滋。

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
#include<map>
#include<vector>
#include<set>
#include<fstream>
#include<sstream>
using namespace std;

map<string,set<int>>name,aut,key,pub,year;
int N,M,id,num;
string na,au,ke,pu,ye,temp,temp1;

int main()
{
	scanf("%d",&N);
	for(int i=0;i<N;i++)
	{
		scanf("%d",&id);
		getchar();//别忘了
		getline(cin,na);
		name[na].insert(id);
		getline(cin,au);
		aut[au].insert(id);
		getline(cin,temp);
		istringstream stream(temp);
		while(stream>>temp1)//分割关键字
		{
			key[temp1].insert(id);
		}
		getline(cin,pu);
		pub[pu].insert(id);
		getline(cin,ye);
		year[ye].insert(id);
	}
	scanf("%d",&M);
	for(int i=0;i<M;i++)
	{
		scanf("%d: ",&num);
		getline(cin,temp);
		cout<<num<<": "<<temp<<endl;
		if(num==1)
		{
			if(name.find(temp)==name.end())
				printf("Not Found\n");
			else
			{
				for(set<int>::iterator it=name[temp].begin();it!=name[temp].end();it++)
					printf("%07d\n",*it);
			}
		}
		else if(num==2)
		{
			if(aut.find(temp)==aut.end())
				printf("Not Found\n");
			else
			{
				for(set<int>::iterator it=aut[temp].begin();it!=aut[temp].end();it++)
					printf("%07d\n",*it);
			}
		}
		else if(num==3)
		{
			if(key.find(temp)==key.end())
				printf("Not Found\n");
			else
			{
				for(set<int>::iterator it=key[temp].begin();it!=key[temp].end();it++)
					printf("%07d\n",*it);
			}
		}
		else if(num==4)
		{
			if(pub.find(temp)==pub.end())
				printf("Not Found\n");
			else
			{
				for(set<int>::iterator it=pub[temp].begin();it!=pub[temp].end();it++)
					printf("%07d\n",*it);
			}
		}
		else
		{
			if(year.find(temp)==year.end())
				printf("Not Found\n");
			else
			{
				for(set<int>::iterator it=year[temp].begin();it!=year[temp].end();it++)
					printf("%07d\n",*it);
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39396954/article/details/79256673