F - 6 C++

题目:

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

思路:

这是个DFS。一开始以为是BFS。。虽然题目说可以从任意位置开始跳,但是既然可以从任意位置开始遍历完真个棋盘就一定可以从第一个位置开始。然后答案输出时记得空一行= =

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int q,p;
typedef pair<int,int> P;
int d[30][30];
int vis[30][30];
P shuzu[30];
int flag;
int dx[8] = {-2,-2,-1,-1,1,1,2,2};
int dy[8] = {-1,1,-2,2,-2,2,-1,1};
char zm[27]={'0','A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z'};
void dfs(int x,int y,int ans)
{
    vis[x][y]=1;
    int i;
    shuzu[ans]=P(x,y);
    if(ans==p*q-1)
    {
        for(i=0;i<=ans;i++)
        {
            P y=shuzu[i];
            cout<<zm[y.first]<<y.second;
        }
        cout<<endl;
        cout<<endl;
        flag=1;
        return;
    }
    for(i=0;i<8;i++)
    {
        int nx=x+dx[i],ny=y+dy[i];
        if(nx>0&&nx<=q&&ny>0&&ny<=p&&vis[nx][ny]==0)
        {
            vis[nx][ny]=1;
            dfs(nx,ny,ans+1);
            vis[nx][ny]=0;
            if(flag)return;
        }
    }
    if(flag)return;
}
int main()
{
    int m,i;
    scanf("%d",&m);
    for(i=1;i<=m;i++)
    {
        memset(vis,0,sizeof(vis));
        flag=0;
        scanf("%d %d",&p,&q);
        d[0][0]=1;
        printf("Scenario #%d:\n",i);
        dfs(1,1,0);
        if(flag==0)cout<<"impossible"<<endl<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zero_979/article/details/79858111