【CodeForces 1277C --- As Simple as One and Two】

【CodeForces 1277C --- As Simple as One and Two】

题目来源:点击进入【CodeForces 1277C — As Simple as One and Two】

Description

You are given a non-empty string s=s1s2…sn, which consists only of lowercase Latin letters. Polycarp does not like a string if it contains at least one string “one” or at least one string “two” (or both at the same time) as a substring. In other words, Polycarp does not like the string s if there is an integer j (1≤j≤n−2), that sjsj+1sj+2=“one” or sjsj+1sj+2=“two”.

For example:

  • Polycarp does not like strings “oneee”, “ontwow”, “twone” and “oneonetwo” (they all have at least one substring “one” or “two”),
  • Polycarp likes strings “oonnee”, “twwwo” and “twnoe” (they have no substrings “one” and “two”).

Polycarp wants to select a certain set of indices (positions) and remove all letters on these positions. All removals are made at the same time.

For example, if the string looks like s=“onetwone”, then if Polycarp selects two indices 3 and 6, then “onetwone” will be selected and the result is “ontwne”.

What is the minimum number of indices (positions) that Polycarp needs to select to make the string liked? What should these positions be?

Input

The first line of the input contains an integer t (1≤t≤104) — the number of test cases in the input. Next, the test cases are given.

Each test case consists of one non-empty string s. Its length does not exceed 1.5⋅105. The string s consists only of lowercase Latin letters.

It is guaranteed that the sum of lengths of all lines for all input data in the test does not exceed 1.5⋅106.

Output

Print an answer for each test case in the input in order of their appearance.

The first line of each answer should contain r (0≤r≤|s|) — the required minimum number of positions to be removed, where |s| is the length of the given line. The second line of each answer should contain r different integers — the indices themselves for removal in any order. Indices are numbered from left to right from 1 to the length of the string. If r=0, then the second line can be skipped (or you can print empty). If there are several answers, print any of them.

Sample Input

4
onetwone
testme
oneoneone
twotwo

Sample Output

2
6 3
0

3
4 1 7
2
1 4

Note

In the first example, answers are:

“onetwone”,
“testme” — Polycarp likes it, there is nothing to remove,
“oneoneone”,
“twotwo”.

AC代码:

#include <bits/stdc++.h>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define endl '\n'
using ll = long long;

int main()
{
    SIS;
    int T;
    cin >> T;
    while(T--)
    {
        string s;
        cin >> s;
        s='#' + s;
        int len=s.size();
        vector<int> v;
        vector<bool> vis(len,false);
        for(int i=1;i<len-4;i++)
            if(s[i]=='t' && s[i+1]=='w' && s[i+2]=='o' && s[i+3]=='n' && s[i+4]=='e')
                vis[i+2]=true,i+=4;
        for(int i=1;i<len-2;i++)
            if(s[i]=='o' && s[i+1]=='n' && s[i+2]=='e' && !vis[i])
                vis[i+1]=true;
            else if(s[i]=='t' && s[i+1]=='w' && s[i+2]=='o' && !vis[i+2])
                vis[i+1]=true;
        for(int i=1;i<len;i++)
            if(vis[i]) v.emplace_back(i);
        len = v.size();
        cout << len << endl;
        for(int i=0;i<len;i++)
            cout << v[i] << " ";
        cout << endl;
    }
    return 0;
}
发布了361 篇原创文章 · 获赞 127 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/qq_41879343/article/details/103572431