HDU-2031,进制转换

Problem Description:

输入一个十进制数N,将它转换成R进制数输出。 

Input: 

输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。 

Output: 

为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。 

Sample Input: 

7 2

23 12

-4 3 

Sample Output: 

111 

1B

-11 

程序代码: 

#include<stdio.h>
#include<string.h>
int a[500];
int main()
{
	int m,n;
	while(~scanf("%d %d",&m,&n))
	{
		int j=0;
		if(m<0)//如果m是负数,先打印负号 
			printf("-");
		m=(m>0 ? m:-m);//统一将m转为正数计算 
		while(m!=0)
		{
			a[j++]=m%n;
			m/=n;
		}
		for(int i=j-1;i>=0;i--)
		{
			if(a[i]>=10)//大于10的要转换成字母 
				printf("%c",(a[i]%10)+'A');//对10求余只剩下个位,再加上A的ASCII码即可 
			else//不大于10的正常输出 
				printf("%d",a[i]);
		}
		printf("\n");
	}
	return 0;
}
发布了260 篇原创文章 · 获赞 267 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/weixin_43823808/article/details/104002981