数据结构——kmp中next数组理解

HDU 3746 Cyclic Nacklace (kmp求循环节)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 22075 Accepted Submission(s): 8987

Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~‘z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input
3
aaa
abca
abcde

Sample Output
0
2
5

题解思路:

主要考察对next数组的使用理解

如果 i%(i-nex[i])==0 说明字符串循环
其中有循环节长度为: i-next[i]
循环次数为: i/(i-next[i])

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

char t[101000];
int nex[100100];
int tlen;
int T;


void getnex()
{
    int j=0,k=-1;
    nex[0]=-1;
    while(j<tlen)
    {
        if(k==-1||t[j]==t[k])
            nex[++j]=++k;
        else  k=nex[k];
    }
}

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",&t);
        tlen=strlen(t);
        getnex();
        int l=tlen-nex[tlen];
        if(tlen!=l&&tlen%l==0){
            printf("0\n");
        }else {
            printf("%d\n",l-nex[tlen]%l);
        }
    }
    return 0;
}

HDU 1358 Period(next数组的理解)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 16834 Accepted Submission(s): 7832

Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input
3
aaa
12
aabaabaabaab
0

Sample Output
Test case #1

2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题解分析:

跟上题同类型,其中循环节长度为: i-next[i]
循环次数为: i/(i-next[i])
O(n)从头遍历,每次匹配成功输出当前匹配长度,匹配长度与循环节的商值即可

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

char t[1001000];
int nex[1000100];
int tlen;
int T;


void getnex()
{
    int j=0,k=-1;
    nex[0]=-1;
    while(j<tlen)
    {
        if(k==-1||t[j]==t[k])
            nex[++j]=++k;
        else  k=nex[k];
    }
}

int main()
{
    int k=1;
    while(scanf("%d",&T)&&T)
    {
        scanf("%s",t);
        tlen=strlen(t);
        getnex();
        printf("Test case #%d\n",k++);
        for(int i=1;i<=T;i++){
            int ans=i-nex[i];
            if(i%ans==0&&i/ans>1){
                printf("%d %d\n",i,i/ans);
            }
        }
        printf("\n");
    }
    return 0;
}
发布了247 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_43658924/article/details/102924354