hdu 1452 Happy 2004(费马小定理+因数和公式+积性函数)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2493 Accepted Submission(s): 1802

Problem Description

Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.

Input

The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000).

A test case of X = 0 indicates the end of input, and should not be processed.

Output

For each test case, in a separate line, please output the result of S modulo 29.

Sample Input

1
10000
0

Sample Output

6
10

分析:

整数分解

#include<iostream>
#include<cstdio>
using namespace std;

int pp(int a,int b) {
    int ret=1;
    while(b) {
        if(b&1) {
            ret*=a;
            ret%=29;
        }
        a*=a;
        a%=29;
        b>>=1;
    }
    return ret;
}

int main() {
    int n;

    while(~scanf("%d",&n)&&n) {
        int ans1=(pp(2,2*n+1)-1)%29;
        int ans2=(pp(3,n+1)-1)%29*pp(2,27)%29;
        int ans3=(pp(22,n+1)-1)%29*pp(21,27)%29;
        printf("%d\n",ans1*ans2*ans3%29);
    }
    return 0;
}
发布了247 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_43658924/article/details/103588691