Q: Simple Line Editor

Q: Simple Line Editor

pop_back
push_back
clear


Description

Early computer used line editor, which allowed text to be created and changed only within one line at a time. However, in line editor programs, typing, editing, and document display do not occur simultaneously (unlike the modern text editor like Microsoft Word). Typically, typing does not enter text directly into the document. Instead, users modify the document text by entering simple commands on a text-only terminal.

Here is an example of a simple line editor which can only process English. In addition, it has two commands. ‘@’ and ‘#’. ‘#’ means to cancel the previous letter, and ‘@’ is a command which invalidates all the letters typed before. That is to say, if you want type “aa”, but have mistakenly entered “ab”, then you should enter ‘#a’ or ‘@aa to correct it. Note that if there is no letter in the current document, ‘@’ or ‘#’ command will do nothing.

Input

The first line contains an integer T, which is the number of test cases. Each test case is a typing sequence of a line editor, which contains only lower case letters, ‘@’ and ‘#’.

there are no more than 1000 letters for each test case.

Output

For each test case, print one line which represents the final document of the user. There would be no empty line in the test data.

Sample Input

2
ab#a
ab@aa

Sample Output

aa
aa

Hint

#include<iostream>
#include<string>
#include<stack>
#include<vector>
#include<queue>
using namespace std;
#define MAX(a,b) ((a)>(b)?(a):(b))
#define N 1000001
int a[N];
int q1[N], q2[N];
int front1, front2, rear1, rear2;
int main()
{
    int T;
    string s;
    vector<char>sta;
    cin >> T;
    while (T--)
    {
        cin >> s;
        for (int i = 0; i < s.length(); i++) {
            if (s[i] == '@') {
                sta.clear();
            }
            else if (s[i] == '#') {
                if (!sta.empty())sta.pop_back();
            }
            else  sta.push_back(s[i]);
        }
        for (auto pos = sta.begin(); pos != sta.end(); pos++) {
            cout << *pos;
        }
        sta.clear();
        cout << endl;
    }
}

猜你喜欢

转载自blog.csdn.net/Sc_Jn/article/details/80289043
Q A
q