PAT甲级---1027 Colors in Mars (20 分)

1027 Colors in Mars (20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:
15 43 71
Sample Output:
#123456

#include<iostream>

using namespace std;

int main(){
    
    
	int a,b,c;
	int len1=0,len2=0,len3=0;
	int a1[10],b1[10],c1[10];
	while(scanf("%d%d%d",&a,&b,&c)!=EOF){
    
    
		do{
    
    
			a1[len1++]=a%13;
			a=a/13;
		}while(a!=0);
		
		do{
    
    
			b1[len2++]=b%13;
			b=b/13;
		}while(b!=0);
		
		do{
    
    
			c1[len3++]=c%13;
			c=c/13;
		}while(c!=0);
		
		printf("#");
		for(int i=len1-1;i>=0;i--){
    
    
			if(a1[i]<10){
    
    
				printf("%d",a1[i]);
			}else{
    
    
				printf("%c",a1[i]-'A'+10);
			}
			
		}
		for(int i=len1-1;i>=0;i--){
    
    
			if(b1[i]<10){
    
    
				printf("%d",b1[i]);
			}else{
    
    
				printf("%c",b1[i]-'A'+10);
			}
		}
		for(int i=len1-1;i>=0;i--){
    
    
			if(c1[i]<10){
    
    
				printf("%d",c1[i]);
			}else{
    
    
				printf("%c",c1[i]-'A'+10);
			}
		}
	}
	
	
	return 0;
}

10分–原因未知
参考答案

#include <cstdio>
using namespace std;
int main() {
    
    
    char c[14] = {
    
    "0123456789ABC"};
    printf("#");
    for(int i = 0; i < 3; i++) {
    
    
        int num;
        scanf("%d", &num);
        printf("%c%c", c[num/13], c[num%13]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44411458/article/details/123227174