PAT A 1042 Shuffling Machine

Shuffling is a procedure used to randomize a deck of playing cards.Because standard shuffling techniques are seen as weak, and in order toavoid "inside jobs" where employees collaborate with gamblers byperforming inadequate shuffles, many casinos employ automaticshuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given randomorder and repeats for a given number of times. It is assumed that theinitial status of a card deck is in the following order:

S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13,J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for"Diamond", and "J" for "Joker". A given order is a permutation ofdistinct integers in [1, 54]. If the number at the i-th position is j,it means to move the card from position i to position j. For example,suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shufflingorder {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If weare to repeat the shuffling again, the result will be: C1, H5, S3, J2,D13.

Input Specification:

Each input file contains one test case. For each case, the first linecontains a positive integer K (<= 20) which is the number of repeattimes. Then the next line contains the given order. All the numbers in aline are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All thecards are separated by a space, and there must be no extra space at theend of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
#include<cstdio>
const int N = 54;
int main() {
	int k, i, j;
	scanf("%d", &k);
	int start[N + 1], end[N + 1], next[N + 1];
	char mp[5] = { 'S','H','C','D','J' };

	for (i = 1; i <= N; i++) {       //为了和下标统一,从1开始
		start[i] = i;
	}
	for (i = 1; i <= N; i++) {       
		scanf("%d", &next[i]);
	}
	
        for (i = 1; i <= k; i++) {
		for (j = 1; j <= N; j++) {
			end[next[j]] = start[j];
		}                                   
		for (j = 1; j <= N; j++) {
			start[j] = end[j];
		}
	}
        
         for (i = 1; i <= N; i++) {
		printf("%c%d", mp[(end[i] - 1) / 13], (end[i] - 1) % 13 + 1);      //注意动手模拟一下花色和数字
		if (i != N) printf(" ");
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/80528943