1037 Magic Coupon (25 分)

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/chen_zan_yu_/article/details/102649087

1037 Magic Coupon (25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43
#include <bits/stdc++.h>
using namespace std;
const int maxn=100010;
int a[maxn],b[maxn];
int main()
{
    int n,m;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&a[i]);
    }
    scanf("%d",&m);
    for(int i=0; i<m; i++)
    {
        scanf("%d",&b[i]);
    }
    sort(a,a+n);
    sort(b,b+m);
    int i=0;
    int j;
    int ans=0;
    while(i<n&&i<m&&a[i]<0&&b[i]<0)
    {
        ans+=a[i]*b[i];
        i++;
    }
    i=n-1;
    j=m-1;
    while(j>=0&&i>=0&&a[i]>0&&b[j]>0)
    {
        ans+=a[i]*b[j];
        i--;
        j--;
    }
    printf("%d",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chen_zan_yu_/article/details/102649087