2017 北京网络赛 E Cats and Fish

时间限制:1000ms
单点时限:1000ms
内存限制:256MB

描述

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

输入

There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn,  ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

输出

For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

样例输入
2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1
样例输出
1 0
0 1
0 3

题意:n条鱼,m只猫,x是时间,给定每一只猫吃鱼的速度,问x时间之后,还剩多少条鱼,又有多少条鱼正在被吃 

模拟即可

#include<iostream>
#include<string.h>
#include<string>
#include<algorithm>
#include<math.h>
#include<string>
#include<string.h>
#include<vector>
#include<utility>
#include<map>
#include<queue>
#include<set>
#define mx 0x3f3f3f3f
#define ll long long
using namespace std;
int n,m,x;
int a[105],vis[105];
priority_queue<int,vector<int>,greater<int> >p;
int main()
{
    while(~scanf("%d%d%d",&m,&n,&x))
    {
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        sort(a+1,a+n+1);
        int now=0;
        for(int i=1;i<=x;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(m==0)
                    break;
                if(i%a[j]==0)
                {
                    if(a[j]==1)
                        m--;
                    if(vis[j]==1)
                    {
                        vis[j]=0;
                        now--;
                    }
                }
                else
                {
                    if(vis[j]==0)
                    {
                        now++;
                        m--;
                        vis[j]=1;
                    }

                }
                if(m==0&&now==0)
                    break;
            }
            if(m==0&&now==0)
                break;
        }
        printf("%d %d\n",m,now);
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/-citywall123/p/11348755.html